Scheduled Maintenance Notice
Scheduled for May 07, 2026 at 8:00 PM – 10:00 PM
Affects
Platform
Under maintenance from 8:00 PM to 10:00 PM
Digital Customer Plattform
Under maintenance from 8:00 PM to 10:00 PM
Completed
May 07, 2026 at 10:00 PMCompleted
May 07, 2026 at 10:00 PMMaintenance has completed successfully
In progress
May 07, 2026 at 8:00 PMIn progress
May 07, 2026 at 8:00 PMMaintenance is now in progress
Planned
May 07, 2026 at 8:00 PMPlanned
May 07, 2026 at 8:00 PMWe will be performing scheduled maintenance on our platform during this time.
The user interface and platform access may be temporarily unavailable.
Data collection and background processes will continue uninterrupted, and no data will be lost.